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Getting Started – What is O-Calc Pro® Line Design? 
O-Calc Pro® Version 6.0 Line Design is Pole Loading Software that dramatically changes the way poles 

can be analyzed. In previous versions, only one pole could be analyzed at a time. A single pole was 

modeled with all appropriate attachments and pole loading regulation parameters, to return a value for 

the pole’s maximum capacity utilization. The calculation determined if the pole was compliant with 

NESC, GO95, or other Safety Standards.  

In O-Calc® Pro Line Design, a line of poles can be modeled and analyzed together, considering the 

interactions between the poles and how load is distributed across the line of poles. This document walks 

you through the various ways to create a line design, as well as the features that are new or different 

from previous versions. 

Some of these features include: 

• Generating a line of poles using a Line Design Wizard Tool 

• Adding existing .pplx files to a line design 

• Linking spans between poles using drag-and-drop functionality 

• Simplified stringing of new spans between poles 

• Connectivity from pole to pole using jumper cables 

• Advanced clearance analysis using 3D clearance buffers 

• Incorporation of maps and client GIS data in new map view 

• Analysis report dedicated to analyzing a circuit of poles 

• 3D View enhancements for easy editing of line designs 

For a more comprehensive review of the new features and options, please see the O-Calc Pro® Line 

Design User Guide.  
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Understanding Line Design Interface 
A new tab can be found next to the existing 3D View, Measure, Charts, and Reports tabs in the O-Calc® 

Pro interface.  

 

This new tab has two main sections; one is identified as the Main Line Design Area, while the other 

contains a set of Line Design Tabs for Poles, GIS Files, Maps, and Clearance Rules.  

Main Line Design Area 
This portion of the interface will display the poles of a line design in a geospatial way, as well as other 

resources that a user would need to accurately create a new line design. This area can display map 

server tiles as well as client GIS Data. 

Line Design Tabs 
The tabs in this portion of the interface allow a user to manage the poles in a line design, as well as 

additional GIS files, maps, and clearance rules.  

Poles Tab 

The Poles Tab will be blank until poles are added to a new line design, or an existing line design has been 

opened. Once poles are added, a numbered list of the poles will be displayed.  

Main Line Design Area Line Design Tabs 
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The numbering of each pole, the number in the parenthesis, indicates the current order for the poles. 

This order is used for other tools, like the order in which stringing is performed and the order in which 

poles are drawn in profile view.  

Pole order can be changed by dragging-and-dropping the items in the list to be above or below another 

item in the list. Additionally, under the View drop-down list in the Poles tab, there is an option called 

Sort/Check Helper, which allows a user to position the mouse overtop of poles, in the order they would 

like them placed. More information on this feature can be found in the full Line Design User Guide.  

GIS Files Tab 

This area allows a user to add to or remove GIS files or layers from the Main Line Design Area. User 

defined data such as Shapefiles and GeoJSON files are examples of GIS layers that can both be added to 

a line design.  

Map Tab 

This area allows a user to display a map in the Main Line Design Area to assist in the modeling of a line 

design. Osmose Vector Tiles can be displayed, which show simplified roads and labels. Additionally other 

Public Domain GIS Data can also be displayed. 
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 Additionally, a background map from OpenStreet, Google Maps, or Bing Maps can be rendered, 

provided that an API Key is entered if required.  

 

For some maps, a key may be required that must be obtained by the user from the host’s website. 

Osmose does not provide a key to the user.  

Clearance Tab 

This tab allows a user to create and manage clearance rules to be applied to the line design. Like the 

standard O-Calc Pro clearance analysis tool, rules can be created to manage violations that may occur 

between spans and various objects like surfaces, foliage and structures. The main difference in O-Calc 

Pro® Line Design is that the clearance rules can be verified in 3D rather than in profile, one vector at a 

time. Furthermore the clearance rules can be applied to the full line at one time, and even include 

different rule definitions based on different surface types. 

Updates to Other Areas & Features 
In addition to the new Line Design Tab, some other areas of the program have been updated to work in 

sync with the line design features.  

3D View Tab 

Most of the changes to other interface areas can be seen in the 3D View tab. The first major change is 

that all poles in a line design can be seen at the same time in the 3D View tab.  

While there is still a compass shown in the 3D View tab, this compass is only shown under the active 

pole of the line design. Only one pole may be active at a time. The components of the active pole are 
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also listed in the inventory. Switching the active pole can be done in the 3D view tab by left-clicking on 

the pole you wish to activate.  

Additionally, new buttons have been added to the bottom right-hand corner of the 3D View tab. These 

buttons control the spacing between the poles in the 3D rendering of the line design. These values do 

not represent actual span lengths between poles, but rather the scaling of the distance between poles 

that are drawn. This will make it easier to view poles that may be greater distances apart. A filter has 

also been added to allow a user to display all spans, those that are linked, or those that are not linked.  

Capacity Calculation 

The capacity meter is set to manual mode in Line Design; the default setting to automatically calculate 

this value has been altered. Typically, the percent maximum capacity utilization is automatically 

calculated for the user each time a change to the model is made. This option can be turned off under 

the Options menu. However, in line design, automatic calculation is turned off by default. This is 

indicated in the bottom ribbon of the interface, right below the capacity utilization window. 

 

Clicking on the “Manual” button will run the calculation for the active pole, provided each pole in the 

line has been assigned a loadcase. To run a calculation on the entire circuit, please see the steps 

outlined in the Performing an Analysis and Reading the Results section. 

Default Loadcase 

In line design, the loadcase is set based on the loadcase from the pole used to start a line. For instance, 

when creating a line design using the wizard, a user will start out with one pole. The loadcase applied to 

this pole will automatically be applied to each subsequent pole created in the wizard. 

Additionally, creating a line design using a set of existing .pplx files will maintain the loadcase that had 

been set on those poles. It is also possible to have poles in a line with different loadcases. In this case, 

when a new pole is added, it adopts the loadcase of the pole identified as pole number 1 in the list of 

poles in the line design.  

Auto-Guy 

The Auto-Guy feature allows a user to take a default guying assembly, and place the entire assembly on 

the pole. The guy wire’s attachment height is set to the point on the pole where the user has right-

clicked, while the anchor is placed in a position that corrects the pole the most.  In Line Design, before 
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the auto-guy functionality can be applied to a pole, this particular pole must have a pole loading 

calculation, which can be run by following the steps outlined in the Auto-Guy section of this document.
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Creating Line Designs 
This section outlines the options for starting a new line design. Primarily, a user will create a line design 

by using the line design wizard, creating one from an existing .pplx file, or creating one from a set of 

.pplx files.  

Using the Line Design Wizard 
The Line Design Wizard is the easiest option for creating a new line design. Typically, this would start 

with a dead-end structure that is modeled in the traditional way; this structure could be considered the 

start or the end of the line.  

 

Once the start or end of the line is created and saved as a .pplx file, the following steps can be used to 

build a line design that has the same components on the subsequent poles as the starting pole.  

1. Open or create a deadend pole 

2. In the Main Line Design Area, select File > New Line Design > Using Line 

Wizard 

3. Ensure maps are displayed to determine where to position poles 

4. Left-click on the map in the Main Line Design Area to place the pole 
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**Note: Accuracy of pole position can be adjusted at any time by 

repositioning the pole; this functionality is outlined in the full O-Calc Pro® 6.0 

Line Design User Guide 

5. Enter a Pole ID if desired, then click ‘OK’ 

6. Verify a red dot is placed on the map for this pole 

This will create the beginnings of a line design. The pole is not added to the poles tab until the line 

design has been finished. Next, to add additional poles to the line design, follow these steps: 

1. Left-click on a place for the next pole 

2. Update the Pole ID 

3. Continue adding as many poles as needed for the line 

4. When finished, click the yellow “Extend” option, in the ribbon of the Main 

Line Design Area 

5. When prompted, name and save the Line Design 

6. Verify each pole is added to the Poles list, each with the correct number 

 

By using the wizard, all of the pole are created and linked together, saving the user time and effort to 

link the spans of each pole to their neighbors.  

Once all poles have been added and modified, the line design can be saved and analyzed. 

Using Existing .pplx Files to Start a Line 
An experienced O-Calc® Pro user will have created many .pplx files in the past. These .pplx files may 

even be part of the same line of poles. Rather than starting from scratch, a user can take existing .pplx 

files and create a new line design from them, provided they have a valid Latitude and Longitude. 
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To begin, open any existing .pplx file. This file will be shown in the 3D View Window as it normally is 

within O-Calc® Pro.  

Next, in the Line Design tab’s main ribbon: 

1. Select File > New Line Design > Start Line with Current Pole(s) 

2. Enter a file name, then save the Line Design File (.pplld) 

3. Click Ok 

This will add the .pplx file to the list of Poles under the Line Design tab.  

Adding Existing .pplx Files to an Existing Line Design 
Once the line has been started, additional existing .pplx files can be added to a design.  

1. In the Poles list of the Line Design Tab, select the File drop-down 

2. Select Add PPLX Files to Line Design 

3. In the pop-up window, select one or more poles to add to design 

a. Hold down CTRL Key to select multiple poles 

4. Click Open 

**Note: A pole that is added using this method must have valid Latitude and 

Longitude coordinates within the .pplx file 

The selected poles are added to the line design window. The added pole will need to be ‘hooked up’ to 

one of the other poles in the line.  
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**Note: If a pole that is added is not within 10 Kilometers of another pole in the line design, an error 

message will display. 

Linking Spans between Poles in a Line Design 
When multiple existing .pplx files are used to create a new Line Design, or are added to a Line Design, 

the individual poles are not linked to one another by the spans. When two spans are linked, it means 

that the span goes from one pole to the next, with the load of that span being shared between all poles 

that the span is on, that are linked.  

Spans are linked for the user when other methods, such as the Line Design Wizard, are used to generate 

a line of poles. When spans are linked, a chain-link symbol will be shown next to that span in the 

inventory list, as shown below.  

 

This symbol indicates that this span is linked to a span on the next pole in the line. Without linking, the 

load of the span on each pole will not be shared, and thus the analysis of the entire circuit will be 

incorrect. 

When existing .pplx files are used to create a line design, the spans are not linked. This connection 

between them must be done manually, using the 3D View window. For example, below is a picture of 

such a scenario: 
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These two poles would need to be connected to analyze them as a single line design; in other words, to 

account for the interactions between the two poles. 

In a line design created with at least two existing .pplx files, go to the 3D View tab. All poles in the design 

will be shown in 3D View, but the compass will display under the active pole.  

 

Notice in the previous image that the compass only appears under one of the poles – this is the active 

one in this design. The active pole is displayed in the Inventory window, and is the pole currently being 

edited. 

**Note: Normal 3D View navigation (zooming, panning, rotating) still function in the same way. 

To link spans from one pole to the spans of another: 

1. Select a span on the active pole in the 3D View tab 

2. Left-click and hold on the span 

3. Drag the cursor, while maintaining the left-click, to the span to be linked to 

the next pole in the line 

4. When the replace symbol is visible, release the left-click 

5. Verify that the spans are now linked in the Inventory window, by noting the 

link symbols next to the linked span. Additionally, the filter option in the 3D 

View window can be set to view any linked or un-linked spans. 
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To link communication spans, or span bundles from one pole to the span bundles of another: 

1. Select the messenger wire of the communication bundle on the active pole 

in the 3D View or Inventory tab 

2. Left-click and hold on the messenger 

3. Drag the cursor, while maintaining the left-click, to the messenger being 

linked to the next pole in the line 

4. When the replace symbol is visible, release the left-click 

5. Verify that the spans are now linked by looking for the chain-link symbol in 

the inventory window; Alternatively, the filter option in the 3D View 

window can be set to view any linked or un-linked spans. 

Rules for Linking Spans 

Certain rules are in place to ensure that linking spans is done in a logical way. Below are the main rules 

that must be followed for spans to be linked together.  

• Spans to be linked must be of the same type (Primary, Secondary, Neutral, etc).  

• Spans to be linked must be of the same description (AAAC 30.58 KDM AKRON, AAC 4 AWG 7 

STRAND ROSE, etc.) 

• Spans cannot be linked if they are already linked to another span 

• Communication bundles that are linked may have different messenger sizes; the messenger 

used to start the link is applied to the rest of the link. Additionally, any communication spans 

from the origin communication bundle are used to replace the communication spans in the 

bundle that is being linked to.  
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**Note: Linking of spans can also be performed in the Main Line Design Area’s map view.  



Osmose O-Calc® Pro 6.0 Confidential Quick Start Guide 

 

©2019 Osmose Utilities Services, Inc.      19 
 

Switching the Active Pole in 3D View 
Note that when connecting existing .pplx files, only the spans on the active pole may be selected and 

linked to spans on an adjacent pole. Once the active pole is connected to adjacent poles, proceed to the 

next pole in the line to continue the linking process. There are two ways to switch the active pole, 

outlined below.  

To switch the active pole in 3D View: 

1. Go to the 3D View tab 

2. Left-click on the next pole in the line 

3. Wait a moment, then verify that the clicked pole is now shown in the 

Inventory window 

4. Continue linking spans 

Alternatively, selecting a different pole from the list of poles in the line design will also change the active 

pole: 

1. Go to the Line Design Tab 

2. In the Line Design Tabs, select the Poles tab 

3. Left-click on another pole in the line 

4. Verify that the selected pole is shown in the Inventory Window 

5. Continue linking spans 

Un-Linking Spans in Line Design 
If for some reason you link two spans that should not be linked, you are able to Un-link them. To un-link 

spans, simply right-click on the linked span on the currently active pole and select “Un-Link Span”. This 

will break the connection for this pole. Next, go to the pole with the other span that was part of this 

connection. Right-click on that span, and select “Un-Link Span”. It is imperative that when spans are un-

linked, both parts of the link should be disconnected, even if this action has already been performed on 

one of the spans involved.  

If both ends of the link are not un-linked, it will not be possible to link together new spans with these, or 

link them back together.  

Connecting Spans with Jumper Cables 
As a new component of O-Calc Pro® 6.0, a user can now model jumper cables between spans on a pole. 

In situations like a double deadend, these jumper cables allow for the connectivity of the model to 

continue, for features like stringing a new span or replacing a span type across an entire line.  

To add a jumper between insulators on a pole, follow these steps: 

1. Select the first insulator that the jumper will start from 

2. Left-click and hold on that insulator, drag-and-drop while maintaining the 

left-click, to the insulator the jumper will terminate at 

3. Upon releasing the left-click, a menu will appear 

4. Select the “Add Jumper” option 

5. Verify that a jumper cable is drawn between the two insulators involved.  



Osmose O-Calc® Pro 6.0 Confidential Quick Start Guide 

20   ©2019 Osmose Utilites Services, Inc.  
 

Jumper cables can also be drawn between an insulator and an object, by using what is called a Terminal. 

The Terminal is a point where the Jumper cables will end, typically placed as a point near equipment, 

such as a transformer.  

Note that jumper cables can go from one insulator, to another, but not loop around back to the original 

insulator. 

         

Using Created Pole to Generate Next Pole 
In Line Design, an entire pole can essentially be copied, and inserted as the next pole in a line. This 

ensures connectivity to the previous pole, as well as ensures that all the spans and equipment from the 

first pole continue onto the next.  

In an existing line design, the following steps can be used to copy a pole and essentially repeat it as the 

next pole in a line.  

1. Select the pole to be copied 

2. In the Main Line Design Area, go to Tools 

3. Select the Extend or Branch Line > Extend Line from Current Pole option 

4. Assign a Pole ID 

5. Click on the map to set the location of the new pole 

6. Click ‘OK’ in the Geolocation Window 

7. Verify that a new pole was added to the map and listed in the Poles tab 

8. Link spans when appropriate 

Splitting Spans to Insert a Pole 
Once an analysis is performed, a user may find that the poles in the line fail because of span lengths that 

are too long, applying too much tension to one or more poles in the line design. To remedy this, an 

option exists to split span lengths, and insert a pole at the midpoint.  

Begin with two connected poles, with spans of any distance. Let’s say 200 feet, as this is the default span 

length in O-Cal Pro.  

1. Go to the Line Design Tabs, under the Poles Tab 

2. Check the boxes for exactly two poles whose spans are to be split 
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3. Select the Edit option in the Poles tab 

4. Select Split Spans and Insert Pole 

 

5. Verify pole added to design 

6. Make appropriate edits to pole and Save 
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Merging Spans to Remove a Pole 
On the other hand, once an analysis is performed, a user may find that a pole is not needed in an area. 

In this situation, an option exists to merge together spans from two selected poles, and remove any 

poles between them.  

Begin with at least three poles, two end poles with one pole between them.  

1. Go to the Line Design Tab, under the Poles Tab 

2. Select (highlight) the pole to be removed 

 

3. Select the Edit option in the Poles Tab 

4. Select Remove Pole and Merge Spans 

5. When prompted, select ‘Yes’ to delete the selected pole 

 

6. Verify pole was removed from design 

7. Make appropriate edits to the remaining poles and Save 
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Performing an Analysis and Reading the Results 
As previously stated, automatic calculation of the loading on a pole is disabled when the Line Design 

features are being used. Instead, when a line is complete, a user has the option to solve a single pole, or 

the entire line.  

Once a line design is finished, use the following steps to generate a report: 

1. In the Main Line Design Area ribbon, select Solve 

2. Choose Entire Line from the menu 

3. Select either fixed or Swept Wind 

a. For Fixed Wind, Set the wind angle, click “OK” 

b. For Swept Wind, set the start angle, end angle and increment for 

analysis, click “OK” 

4. The report will generate in the Reports tab 

The report generated in the reports tab will look something like this: 

 

On this report, several pieces of information are provided: 

• Name of Line Design in Upper-left corner 

• Overall Worst Wind Direction 

• Worst Pole in the Line – or the pole with the highest MCU under the worst-case 

conditions 

• The value of the worst Pole’s MCU 

• In subsequent sections, each wind angle is shown for the calculation that was run, 

along with values for each pole in the line, given a certain wind angle 

o GCU – Groundline Capacity Utilization 

o VCU – Vertical Capacity Utilization 

o TCU – Total Capacity Utilization 

o MCU – Maximum Capacity Utilization 
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• Guying information would also be provided, if guying were present on any poles in 

the line.  

An analysis can also be run on an individual pole. To do this, select a pole from the list in the Line Design 

area.  

1. In the Main Line Design Area ribbon, select Solve 

2. Choose Current Pole from the menu 

3. The calculation will run, and the Capacity Display will show the overall MCU 

4. More details can be seen for this pole in the Reports tab, by running any of 

the available reports.  
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Useful Features and Tools 
In the Main Line Design Area ribbon, there are several additional dropdown menus. This list contains 

several features that may be useful when getting started with line design.  

Profile View 

It is possible to view a profile of a set of poles in a line, like how schematic view is displayed for a single 

pole in previous versions of O-Calc Pro®. To utilize this feature, follow these steps: 

1. Complete and save a line design 

2. Check the poles to be included in the profile from those listed in the Poles 

Tab 

3. In the Main Line Design Area, select the View drop-down list 

4. Select Profile View 

5. Verify poles in the profile view in the Charts tab 

 

Profile view can be extremely useful, especially in cases where elevation data is significant to the 

analysis of the line.  

Other ‘View’ Options 

Additional options are available to help a user navigate around the Line Design Area. The ‘View’ drop-

down list in the Main Line Design Area ribbon provides several options for easily navigating to a location.  

The Zoom to Poles option will pan to and focus on the selected poles in the Main Line Design Area.  

The Center on Coordinate option allows a user to enter a specific coordinate in the Geolocation 

window, and will move to that location.  
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The Center on Address option allows a user to type in an address, which will then move the center of 

the display to that location.  

Performing Stringing and Adding Drops 

A valuable tool available is the ability to perform stringing, or attach a span to the entire length of a line, 

running from one pole to the next. First, a default stringing assembly must be set up.  

1. In the Master or User Catalog, find a stringing assembly 

a. An assembly could be any crossarm or insulator with a wire on it, or 

a span head guy 

2. Right-click on the desired assembly, and select Set Line Design Stringing 

Assembly 

3. In the line design tab, select (check) all the poles that you wish to add the 

stringing assembly to 

a. Pole order is important here; stringing is performed from the pole 

identified as 1, to 2, to 3, and so on. Poles out of order will have the 

stringing assembly drawn in that order.  

4. In the Tools drop-down menu in the line design tab, select Perform 

Stringing 

5. Select either all of the poles, or the selected (checked) poles 

6. Enter the height at which the stringing assembly will be placed; click “OK” 

7. Verify that the stringing assembly has been added to all the selected poles 

Once a span has been placed using this option, additional edits can be made. These can include changing 

the positioning of the insulator on each pole, or changing properties of the span itself.  

To add drops to a pole, a similar process is used: 

1. In the Master or User Catalog, find a stringing assembly 

a. An assembly could be any crossarm or insulator with a wire on it, or 

a span head guy 

2. Right-click on the desired assembly, and select Set Line Design Stringing 

Assembly 

3. In the line design tab, select the pole you wish to add drops to; if multiple 

poles are checked, the drops will be added to the active pole 

4. In the Tools drop-down menu in the line design tab, select Add Drops to 

Current Pole 

5. Enter the height at which the drop will be placed on the pole; click “OK” 

6. In the main line design drawing area, notice the cursor display lat and long 

values wherever it is place. Click on the screen where the service drop or 

drops should end.  

a. Clicking in multiple spots will add a service drop ending at each of 

the clicked lcoations 

7. When done placing drops, click the yellow Add Drops (Click here when 

done) button in the main line design ribbon 

After placement, these can be edited as well.  
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What Next? 
Congratulations! You have successfully finished the O-Calc Pro® Line Design Quick Start Guide. You are 

well on your way to becoming a Line Design expert! 

Additional material on these and more advanced topics can be found in the Line Design User Guide. 

Plus, there are YouTube video’s and wiki page articles available online for review, each with a focus on a 

particular topic.  

https://www.youtube.com/playlist?list=PL1ZgnYd0lNNU2sgyeQeA9klcZdcIFpZ26
http://o-calcpro.com/wiki/

